読者です 読者をやめる 読者になる 読者になる

MessagePack 0.2.1 リリース

バイナリシリアライズ形式「MessagePack」のバージョン0.2.1をリリースしました。

Ruby版はgemで。

$ gem install msgpack
$ irb -rubygems
require 'msgpack'
packed = [0, true, false, nil].to_msgpack
p MessagePack::unpack(packed)  #=> [0, true, false, nil]

※2008-12-07 追記:既知の問題:
msvc版rubyでgem install msgpackしようとすると、拡張ライブラリがコンパイルできずエラーになるようです。絶賛パッチ募集中orz
win32環境向けにバイナリを配布すれば良いのか…しかしバイナリgemの作り方が分からない…。